Skip to main content

@check/deps@0.3.3
Built and signed on GitHub Actions

Check if dependencies are up to date, similar to npm outdated. Supports npm and jsr specifiers.

This package works with Deno
JSR Score
100%
Published
2 months ago (0.3.3)
I
DenoJson

Describes the structure of a Deno configuration object.

I
DenoLock

Represents the structure of a Deno lock file.

I
DenoPackages

Represents the packages used in a Deno project.

f
fetchJsrPackageMeta

Fetches package metadata from the jsr.io service.

f
fetchNpmPackageMeta

Fetches metadata for an npm package from the npm registry.

f
getDenoLockPath

Constructs the path to the 'deno.lock' file within a working directory.

I
JsrPackageMeta

Represents package metadata retrieved from jsr.io

I
NpmPackageMeta

Represents the metadata for an npm package as retrieved from the npm registry.

c
Package

Represents a single external package dependency.

T
PackageRegistry

An enumeration of supported (and unsupported) package registries.

f
readDenoConfig

Reads Deno configuration files (deno.json, deno.jsonc, etc.) from a specified base directory.

f
tryReadJsoncFile
No documentation available