Skip to main content

@fx/nix@0.1.0

This module provides a function to setup Nix

Works with
This package works with Bun
This package works with Node.js
This package works with Deno
JSR Score
76%
Published
2 months ago

Module: Nix

dagger-min-version deno compatibility

Returns a Container with Nix installed using DeterminateSystems/nix-installer.

🚀 Usage

dagger -m github.com/tsirysndr/daggerverse/nix call \
   setup-nix terminal

🛠️ Arguments

Name Description Required
src Optional context directory. false

👨‍💻 Programmatic usage

import { setupNix } from "jsr:@fx/nix";

const ctr = await setupNix(".");

const version = await ctr.withExec(["nix", "--version"])
  .stdout();

console.log(version);

Built and signed on
GitHub Actions
View transparency log

Add Package

deno add @fx/nix

Import symbol

import * as mod from "@fx/nix";

Add Package

npx jsr add @fx/nix

Import symbol

import * as mod from "@fx/nix";

Add Package

yarn dlx jsr add @fx/nix

Import symbol

import * as mod from "@fx/nix";

Add Package

pnpm dlx jsr add @fx/nix

Import symbol

import * as mod from "@fx/nix";

Add Package

bunx jsr add @fx/nix

Import symbol

import * as mod from "@fx/nix";