Skip to main content
It is unknown whether this package works with Cloudflare Workers, Node.js, Deno, Bun, Browsers
It is unknown whether this package works with Cloudflare Workers
It is unknown whether this package works with Node.js
It is unknown whether this package works with Deno
It is unknown whether this package works with Bun
It is unknown whether this package works with Browsers
JSR Score
47%
Published
2 weeks ago (1.0.0)

...this is simple ugly monkey-patch...

why?

This awesome package during integration with deno project has little ts incompatibility

  • suppose this place:

So I've decided to fix it by myself.

how?

add any type in this place... :D

Add Package

deno add @nik-kita/hono-zod-middleware-monkey-patch

Import symbol

import * as mod from "@nik-kita/hono-zod-middleware-monkey-patch/";

Add Package

npx jsr add @nik-kita/hono-zod-middleware-monkey-patch

Import symbol

import * as mod from "@nik-kita/hono-zod-middleware-monkey-patch/";

Add Package

yarn dlx jsr add @nik-kita/hono-zod-middleware-monkey-patch

Import symbol

import * as mod from "@nik-kita/hono-zod-middleware-monkey-patch/";

Add Package

pnpm dlx jsr add @nik-kita/hono-zod-middleware-monkey-patch

Import symbol

import * as mod from "@nik-kita/hono-zod-middleware-monkey-patch/";

Add Package

bunx jsr add @nik-kita/hono-zod-middleware-monkey-patch

Import symbol

import * as mod from "@nik-kita/hono-zod-middleware-monkey-patch/";