Skip to main content

latest

Please go to: https://jsr.io/@yieldray/json-rpc-ts

This package works with Bun, Cloudflare Workers, Node.js, Deno, Browsers
JSR Score
82%
Published
3 months ago (0.1.3)
class JSONRPCError
extends Error

Constructors

new
JSONRPCError(object: JSONRPCErrorInterface)

Properties

The error codes from and including -32768 to -32000 are reserved for pre-defined errors. Any code within this range, but not defined explicitly below is reserved for future use. The error codes are nearly the same as those suggested for XML-RPC at the following url: http://xmlrpc-epi.sourceforge.net/specs/rfc.fault_codes.php

Add Package

deno add @ray/json-rpc-ts

Import symbol

import { JSONRPCError } from "@ray/json-rpc-ts";

Add Package

npx jsr add @ray/json-rpc-ts

Import symbol

import { JSONRPCError } from "@ray/json-rpc-ts";

Add Package

yarn dlx jsr add @ray/json-rpc-ts

Import symbol

import { JSONRPCError } from "@ray/json-rpc-ts";

Add Package

pnpm dlx jsr add @ray/json-rpc-ts

Import symbol

import { JSONRPCError } from "@ray/json-rpc-ts";

Add Package

bunx jsr add @ray/json-rpc-ts

Import symbol

import { JSONRPCError } from "@ray/json-rpc-ts";